NorEast Fishing Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hey CA hows it goin.....my problem happend while I was casting a Tica Gemeni and the reel was engaging in the middle of the cast bringin it to a screeching hault. I`ve oiled the reel after almost every time out, any clue whats goin on ...I don`t really have a problem casting my smaller setup just this one any help would be appreciated Thanx................John
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
AL I`m usin 65lb whiplash and I know now its not the reel cause Tica sent me a new one (thumbs up to them only a 7 day turnaround and they even swapped my silver taurus for the new black saltwater version @ no charge) I think it might be the combination of the braid and the stick I`m usin and me of course.... its on a 10'one piece breakaway I think the blank is a 1209.....could it be generating to much force ,causing the braid to dig in........what do ya think??........thanx John
 

·
Registered
Joined
·
493 Posts
Braid needs to be wound on really, really tightly to keep it from burying; it should be hard as a rock. Some guys can do it by hand but I bring all my reels to a shop with a heavy duty winder to get it on tight. Other alternative is to go out to open water, tie on a small sinker to your braid, let out all your braind and wind against a steady 10 knot straight-line course.
 

·
Registered
Joined
·
2,425 Posts
John,

I am beginning to see your problem! That is the reason why I asked you the type of line you are using because I was suspecting that the line was digging into the reel.

Crag is correct?he wrote -
?Braid needs to be wound on really, really tightly to keep it from burying; it should be hard as a rock. Some guys can do it by hand but I bring all my reels to a shop with a heavy duty winder to get it on tight... ?

You can still use whiplash but don?t fill the line to the rim otherwise you will be running to the same scenario again. I used to use heavy whiplash line but I switched to the Powerpro braid and it eliminated that problem! Also, you may need to work on your casting?.I have a suspicion that you are putting too much force into your cast (hence- line digging deep into the spool).

Please make the adjustments and let me know. We will solve this problem before the season starts. :)

"Crazy" Alberto
[email protected]
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top